Announcement

Collapse
No announcement yet.

Can I put back anaerobic compost back into the HotBin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HotBinDjinn
    replied
    Originally posted by Newbiecomposter View Post
    Hi all. Looking for some advice please. I’ve been using the bin for 6 weeks and finally understood how to get it hot and it’s working well now. I took the front off this morning just to check and it looks (and smells) pretty anaerobic. I’ve probably removed the hatch too early. Do I just leave it now, wait and hope that will change over time, or do I remove it all. If I remove it can it be fed back in to the HotBin? Thank you.
    If your composter is running hot and you think its just the bottom layer that is anaerobic, I would scrape some of it out, mix it with a little dry material and some fresh material and put it back in the top and see what happens. Don't be afraid to experiment. The heat should kill any of the smelly stuff. I find mine starts to smell just a little sour before it gets properly hot and now I just let it do its thing. The bottom layer can sometimes get a little smelly if rain water has soaked in. If that's the case, it could just be wet compost and it just needs dried out.

    Leave a comment:


  • WeeVee
    replied
    Welcome!

    As your bin is just starting to fire on all cylinders, I’d be inclined to remove the anaerobic stuff from the bottom and pop it in a container to dry out for a while. Perhaps mix some bark and paper in to assist and give it a mix now and then.

    Then I’d clean out the the base of the bin, clear the air holes and rebuild your twig and bark base to ensure good air flow again. Let the newer stuff in the bin that you know is composting well drop down, then you can crack on adding in the top knowing the base is good.

    If the smelly stuff dries out sufficiently you can add it back at some point with plenty of bark and paper.

    Hope that helps.

    Leave a comment:


  • Can I put back anaerobic compost back into the HotBin

    Hi all. Looking for some advice please. I’ve been using the bin for 6 weeks and finally understood how to get it hot and it’s working well now. I took the front off this morning just to check and it looks (and smells) pretty anaerobic. I’ve probably removed the hatch too early. Do I just leave it now, wait and hope that will change over time, or do I remove it all. If I remove it can it be fed back in to the HotBin? Thank you.
Working...
X